May 28, 2017

WordPress 4.7.2 Security Release

WordPress 4.7.2 is now available, and is a security release for all previous versions of WordPress.

We strongly encourage you to update your sites immediately.

WordPress versions 4.7.1 and earlier are affected by three security issues:

  1. The user interface for assigning taxonomy terms in Press This is shown to users who do not have permissions to use it.
  2. WP_Query is vulnerable to a SQL injection (SQLi) when passing unsafe data. WordPress core is not directly vulnerable to this issue, but we’ve added hardening to prevent plugins and themes from accidentally causing a vulnerability.
  3. A cross-site scripting (XSS) vulnerability was discovered in the posts list table.

Upgrade WordPress TODAY

If you need assistance with upgrading, please schedule your WordPress upgrade today via our WordPress Upgrade Service.

Anyone who is already subscribed to one of our upgrade packages has already been upgraded to WordPress 4.7.2.  If you’d like to ensure that your site is always up to date, please check out our WordPress Maintenance Packages.

WordPress 4.7.1 Security Release

WordPress 4.7.1 is now available, and is a security release for all previous versions of WordPress.

We strongly encourage you to update your sites immediately.

WordPress versions 4.7 and earlier are affected by eight security issues:

  1. Remote code execution (RCE) in PHPMailer – No specific issue appears to affect WordPress or any of the major plugins we investigated but, out of an abundance of caution, we updated PHPMailer in this release. This issue was fixed in PHPMailer thanks to Dawid Golunski and Paul Buonopane.
  2. The REST API exposed user data for all users who had authored a post of a public post type. WordPress 4.7.1 limits this to only post types which have specified that they should be shown within the REST API. Reported by Krogsgard and Chris Jean.
  3. Cross-site scripting (XSS) via the plugin name or version header on update-core.php. Reported by Dominik Schilling of the WordPress Security Team.
  4. Cross-site request forgery (CSRF) bypass via uploading a Flash file. Reported by Abdullah Hussam.
  5. Cross-site scripting (XSS) via theme name fallback. Reported by Mehmet Ince.
  6. Post via email checks mail.example.com if default settings aren’t changed. Reported by John Blackbourn of the WordPress Security Team.
  7. A cross-site request forgery (CSRF) was discovered in the accessibility mode of widget editing. Reported by Ronnie Skansing.
  8. Weak cryptographic security for multisite activation key. Reported by Jack.

Thank you to the reporters for practicing responsible disclosure.

In addition to the security issues above, WordPress 4.7.1 fixes 62 bugs from 4.7. For more information, see the release notes or consult the list of changes.

Upgrade WordPress TODAY

If you need assistance with upgrading, please schedule your WordPress upgrade today via our WordPress Upgrade Service.

Anyone who is already subscribed to one of our upgrade packages has already been upgraded to WordPress 4.7.1.  If you’d like to ensure that your site is always up to date, please check out our WordPress Maintenance Packages.

WordPress.com Security Breach

Automattic has reported that there was a recent security incident which could have potentially made account passwords visible.  If you have a WordPress.com account it is highly recommend that you update your password.

NOTE: This does not affect self hosted WordPress sites, but it is still a good idea to update passwords from time-to-time.

WordPress 3.0.5

WordPress 3.0.5, was released on February 9, 2011 and is a maintenance release that addresses two moderate security issues.

While upgrading is not required, it is recommended.

Schedule your WordPress upgrade today via our WordSprung WordPress Upgrade Service.